Back to overview
Degraded
Intermittent Connection Issues
Mar 17, 2026 at 6:30pm UTC
Affected services
SkyCiv Platform and GUI
SkyCiv Solvers
SkyCiv API v3
SkyCiv Quick Design
Resolved
Mar 18, 2026 at 9:00am UTC
Issues have been resolved and services should be back to normal.
Affected services
Created
Mar 17, 2026 at 6:30pm UTC
We are aware of intermittent connection issues when using some ISPs. It seems like a global issue with most countries affected. We are monitoring the situation to understand if there's anything that can be done on our side, but at this moment it seems out of control. More updates will follow as we learn more about the situation.
Affected services