Back to overview
Resolved

SkyCiv Down

Sep 3, 2026 at 5:30am UTC
Affected services
SkyCiv Platform and GUI
SkyCiv Solvers
SkyCiv API v3
SkyCiv Main Webpage
SkyCiv Quick Design

Resolved
Sep 3, 2026 at 7:10am UTC

The issue has now been resolved all services are back online

Created
Sep 3, 2026 at 5:30am UTC

We are currently experiencing an unexpected service disruption affecting our platform.

Our team is investigating the issue and working to restore service as quickly as possible. We apologise for the disruption and appreciate your patience.